Fl0W

General Member
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Fl0W

  • Rank
    Learner License

Personal Information

  • Drives :
    2001 Subaru Legacy 250S EJ25 Non-turbo fully stock apart from 17 x 7.5 inch black ROH wheels
  • Interests
    Love cars, volleyball player, odd video game here and there
  • Location
    Christchurch, NZ
  • Occupation
    Full Time Student studying towards a Bachelor of Engineering

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. ah i see. I might have to take it to an auto electrician then. Hopefully that solves my problem as well! Thanks for the help!
  2. oh I never thought about that, by checking the alternator do you mean testing it using a multimeter or just having a look at the cables coming from it? and did you just replace the alternator after you found it was the problem? Thanks!
  3. Hey Guys, sorry if this is in the wrong place or somebody has a similar post but I've got a number of check engine fault codes on my 2001 BH9 Legacy 250S EJ25 (always run on 95 petrol) they are P0390, P0365 and I did have a P0130 code which might've been before I replaced the O2 sensor post cat. The other 2 codes, which I believe both relate to the camshaft position sensor. It seems to be the case because when the car is at operating temp it loves to dip very low on idle sputtering and stuttering, loss of power and almost dying, etc. I ended up buying a new camshaft position sensor from supercheap and I've replaced it with the one that lives on the passenger side towards the front of the engine near the engine oil filler tube. But I've still got the same codes after resetting and I've tried a lot of other things like injector cleaner and I've cleaned the throttle body replaced air filter added (mbl8 oil additive I think?) oilange with filter every 10k km and all that jazz. It also has some type of tick along the whole rev range, to me it sounds like it's coming from the top end on the passenger side. Other than that the car runs mint when it feels like being normal but it guzzles fuel like crazy, pretty much almost 15-17 litres /100km around town. Sorry about the novel I just wrote but I'm out of ideas and I am a student so any help would be much appreciated!