• Current Donation Goals

sooby

USB options for adding to exisiting BP headunit?

13 posts in this topic

Howdy folks,

Collecting our new 2007 BP legacy in a couple of days and noticed stock headunit lacks USB functionality. I remember a thread here mentioned there was an aftermarket gizmo you could wire into the headunit to enable connecting of a USB card with mp3's on it, but can't find it again frustratingly!

I did come across the auction below on trade me, seems to fit the bill and add bluetooth:

http://www.trademe.co.nz/motors/car-parts-accessories/subaru/accessories/auction-1006158617.htm

Are there any other options out there for adding a USB port without replacing the factory $1,000 fascia + headunit combo?

Share this post


Link to post
Share on other sites

Hi,

I have just installed the Grom unit (see link Andy_Mac pointed you to), it works well. What type of headunit have you got? When I was looking for a solution the thing seems to be the Grom units are for the Kenwood stereos (the normal one , and there are heaps of models) and then there are 'Anycar' units for the Macintosh stereos.

Cheers

Share this post


Link to post
Share on other sites

cheers Andy_Mac! Seems my google skills are lacking...

 Colourfyre said:
Hi,

I have just installed the Grom unit (see link Andy_Mac pointed you to), it works well. What type of headunit have you got? When I was looking for a solution the thing seems to be the Grom units are for the Kenwood stereos (the normal one , and there are heaps of models) and then there are 'Anycar' units for the Macintosh stereos.

Cheers

ah, thanks for that info. Not sure which head unit I have, here is a photo of it: https://trademe.tmcdn.co.nz/photoserver/full/436876130.jpg are you able to tell from that?

Share this post


Link to post
Share on other sites

cool, thanks Colorfyre!

How long is the cord on the Grom unit, would it reach to the centre console?

Share this post


Link to post
Share on other sites

Do you need USB? Or do you just need AUX?

I have the same head unit in my outback - the AUX button didn't do anything when pressed - so I got an adapter off trademe and installed the aux port in the centre console bin (factory location next to the power supply in the centre console) - now the factory AUX button on the stereo works!

http://www.trademe.co.nz/Browse/Listing.aspx?archive=1&id=936941441

Edited by ADIKT

Share this post


Link to post
Share on other sites

The cord on the Grom unit wasn't too long, I installed the unit above the passenger footwell (sticky pad attached to electrical box on the side of the HVAC fan unit). I did this because I wanted to run the microphone up the passenger A pillar to avoid interference with electrical cords on the other side (the passenger A pillar only has what I think is the ariel wire). I don't think you would get enough wire to run it right into the centre console box, but I assume you could use a usb extension cord, even a flush mount usb socket installed in the centre box then wired back to the GROM box.

Share this post


Link to post
Share on other sites

thanks guys,

Quite keen on the USB socket, as we use USB sticks instead of cd's. Adikt, our Legacy lacks the AUX 3.5mm socket in the centre console so I'm guessing this just made things a bitter harder than your install? If I understood you correctly, you already had a AUX socket in centre console and it all worked after installing that wiring harness you linked to?

Cheers Colourfyre, appreciate the advive on the Grom unit. As we don't need idevice integration I'm still leaning towards this one on trade me: http://www.trademe.co.nz/Browse/Listing.aspx?id=1006158617 mainly because it has a USB socket + being cheaper is a bonus.

Share this post


Link to post
Share on other sites
 sooby said:
thanks guys,

Quite keen on the USB socket, as we use USB sticks instead of cd's. Adikt, our Legacy lacks the AUX 3.5mm socket in the centre console so I'm guessing this just made things a bitter harder than your install? If I understood you correctly, you already had a AUX socket in centre console and it all worked after installing that wiring harness you linked to?

Cheers Colourfyre, appreciate the advive on the Grom unit. As we don't need idevice integration I'm still leaning towards this one on trade me: http://www.trademe.co.nz/Browse/Listing.aspx?id=1006158617 mainly because it has a USB socket + being cheaper is a bonus.

Not quite - I had the button on stereo - with no socket in centre console

Purchased that adapter and a couple cables - ran the wires and drilled a hole in centre console for the socket.

After installing the cables the button on stereo started working

These are the 3 cables I used to make it work:

http://www.trademe.co.nz/Browse/Listing.aspx?archive=1&id=936941441

http://www.ebay.com/itm/3-5mm-1-8-Stereo-Female-to-2-Male-RCA-Jack-Adapter-AUX-Audio-Y-Cable-Splitter-/361291038063

http://www.ebay.com/itm/1pc-Car-Dash-Flush-Mount-3-5mm-Aux-Audio-Socket-Extension-Adapter-Cable-Lead-3ft-/321698930157?hash=item4ae6c01ded:g:mjgAAOSwrklVCR7T

Can get pics later on of the centre console

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now