benyu0926

Car started making weird noise

13 posts in this topic

Was driving my car home tonight (2007 Legacy GT JDM), stopped at the lights and then took off, this weird exhaust-y noise came from the front of my car closer to engine bay, I thought it was a Honda next to me at first but then realised it car from my car. I stopped on the side and turned off the car and started it back up again, still had that noise.. A bit louder through the lower rpms, and I can't really hear my exhaust from the back (HKS hi flow exhaust).. Also feels like there's less power..

 

Gonna take her to the mechanic tomorrow morning, but any ideas what it could be? I checked under the hood once I got home, couldn't find anything unusual..

Share this post


Link to post
Share on other sites

Exhaust gasket blowout somewhere.

 

Or just for a total random one, idler pulley bearing is about to die.

Share this post


Link to post
Share on other sites
9 minutes ago, boon said:

Exhaust gasket blowout somewhere.

 

Or just for a total random one, idler pulley bearing is about to die.

Would exhaust gasket blowout cause loss in power? I think my car lost a bit of power since it started making that noise...
Idler pulley bearing, whats the damage like on the bank usually?

Share this post


Link to post
Share on other sites
23 minutes ago, benyu0926 said:

 I thought it was a Honda next to me

xDxD

 

No check engine light?

Share this post


Link to post
Share on other sites
4 minutes ago, Subru said:

xDxD

 

No check engine light?

Yea, turns out the my subie wanted to show it's inner Honda..

No check engine light..

Share this post


Link to post
Share on other sites
1 minute ago, sobanoodle said:

Post a video. Curious

Will take a video and post it tomorrow, don't wanna wake any neighbours up at this hour..

Share this post


Link to post
Share on other sites
4 minutes ago, benyu0926 said:

Will take a video and post it tomorrow, don't wanna wake any neighbours up at this hour..

 

Did you get the brakes sorted in the end? 

Share this post


Link to post
Share on other sites
Just now, sobanoodle said:

 

Did you get the brakes sorted in the end? 

I'm waiting on some brake hardware to arrive, gonna change the brake hardware and then try and clean up the brakes as much as possible and hopefully it'll make a difference... So far it still sounds like 1000 dying kittens...

Share this post


Link to post
Share on other sites

Could be down on power if its a big enough leak pre turbo. Could almost be something on the intake side too. Torn intake pipes can make some weird flappy/buzzy noises and would definately have a decent impact on performance

Share this post


Link to post
Share on other sites
1 minute ago, Andy_Mac said:

Could be down on power if its a big enough leak pre turbo. Could almost be something on the intake side too. Torn intake pipes can make some weird flappy/buzzy noises and would definately have a decent impact on performance

At first I thought it was intake too, but had a look at it, checked filter and everything and it seemed fine... Think it could be a gasket leak then... Hopefully..

Share this post


Link to post
Share on other sites

Lot more to it than just by the filter. You'd have a hard time knowing if the preturbo pipe or throttlebody one was torn visually, wouldn't necessarily make a heap of noise with idle load either. 

Regardless, the mechanic should be able to narrow it down in a jiffy. 

1 person likes this

Share this post


Link to post
Share on other sites

Went Pitstop, it was an exhaust leak by the secondary cat.. Getting it straight piped and deleting the secondary cat as the cat's half broken anyway, hopefully it's only a little bit louder..

@sobanoodle you still want a video? I took one and it basically sounds like exhaust leak hahaha

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Similar Content

    • By IZichard
      So my gc8 has a moderate amount of smoke coming from beneath the turbo heat shield. It starts smoking 3-4 mins after starting the engine. Turbo is a vf29
       
      I initially thought it was oil burning on the uppipe from the leaking drivers side cam cover gasket. I replaced this and it is no longer leaking but the smoke continues. I have done maybe 100kms since replacing the cam cover gasket.
       
      The car still drives and boosts normally with no strange noises.
       
      I removed the turbo and replaced the oil drain hose, coolant drain hose and both exhaust gaskets. The turbo impeller has no side to side play and is not contacting the housing on the compressor or exhaust side. This did not fix the issue.
       
      The front right cv boot is still intact.
       
      Could this be the turbo's seal on only the exhaust side of the turbo? I checked the intercooler while it was off and there was not much oil in there. Just the very small amount that is normal.
       
      Any ideas would be greatly appreciated as I am now at bit of a loss. At this stage all I can think of is just driving it some more to see if it is just residue burning off. The amount of smoke makes me think it would be something more than residue though.
    • By GuyHolden
      Hey Guys I have basically finished my ez30 turbo project and I am looking for someone to remote tune it. Has anyone had any experience with remote tuning?
    • By west_minist
      Just sharing the information I am working on another Raptor Supercharged H6 3.0 5EAT
      https://www.facebook.com/groups/SubaruTuningInternational/permalink/287129068422598/
      http://www.xtremeracingtuning.com/forum/viewtopic.php?f=40&t=748
       
      https://www.facebook.com/XtremeRacingTuning/
      https://www.facebook.com/groups/SubaruTuningInternational/
       
  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    37,082
    Total Topics
    525,611
    Total Posts