sh76

Bloody secondary air pump!

Recommended Posts

On 8/01/2019 at 2:02 PM, 95svx said:

Hi! Have the same issue on my 2009 Forester XT. There is a product recall for this issue. https://www.recalls.govt.nz/recall/subaru-forester-impreza-legacy-outback-wrx-model-years-2007-2014 and can melt the pump! I have contacted Armstrong in regards to replacing... waiting to hear back.

Here is the US info https://subaru.oemdtc.com/495/wtm-73-secondary-air-injection-pump-relay-2007-2014-subaru

What does the system do exactly? It helps remove unwanted hydrocarbon emissions, air is injected post combustion for a predetermined amount of time after the engine is started. The system is only operational for a small amount of time post start (the amount of time varies depending on engine temperature, but is typically around 30-60 seconds), and inactive thereafter. It has no effect on engine performance or fuel efficiency it is solely there for emissions control.

Hope this helps!

Cheers

John

Hi what needed up happening with this? Did Armstrong fix it? 

Share this post


Link to post
Share on other sites
10 hours ago, StellaWrx said:

Hi what needed up happening with this? Did Armstrong fix it? 

I had my recall done for this last week.

 

I believe all they do is replace a relay as the relays in certain cars had the problem of not turning off which means the pump would stay on and potentially burn out

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.