wrcfan21

General Member
  • Content Count

    18
  • Joined

  • Last visited

  • Days Won

    1

wrcfan21 last won the day on November 4

wrcfan21 had the most liked content!

Community Reputation

25 Positive

About wrcfan21

  • Rank
    Forum Member

Personal Information

  • Drives :
    Subaru

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. That really sucks man. I’ve just had my engine rebuilt after a similar experience. There’s a few second had engines on trademe but what’s the history of it going to be like? I nearly put a second hand engine in mine but opted for a new shortblock. Similar dollars (not including rebuilt heads, gaskets, seals etc) but you start with basically a new engine. Sent from my iPhone using Tapatalk
  2. Another update. The car was tuned last week by WRC Developments in Napier. I'm very happy with the results. Graham was very professional and definitely knows his stuff! The car feels the best it ever has.
  3. So just an update on my engine rebuild. Speedhub in Pukekohe supplied me with a new W20C shortblock. They also supplied a new oil cooler and cleaned my AVCS cam gears. The heads were sent to a local engine reconditioner who sourced a new camshaft, fitted new stem seals and reset the valve clearances. Engine was reassembled locally by my mechanic. I sourced new oil pump, head gaskets, O rings, seals etc as well. A new clutch was also fitted. Car has been running on a break in tune for the past couple weeks. Tuner also disabled all the TGV codes and secondary air pump codes as I deleted these while the engine was out. I fitted a Crawford Air Oil Separator V2 while buying bits for the rebuild and purchased a baffled sump from James Marshall Motorsport. So far so good. It's definitely getting a dyno tune this time once it's run in!
  4. Thanks Pat I’ve found a new W20C shortblock. Once everything is back together and run in WRC Developments in Napier will do the tune. You guys have been very helpful. It’s great to see you being active in this community! Sent from my iPhone using Tapatalk
  5. Another random question. The shop doing the heads has asked what the valve clearance should be. He recons it is different for this model compared to older STi's. I can only find the EJ257 manual online. Will the clearance be the same?
  6. Thanks for the info. I’ve been quoted $550+gst for the 1 cam from subaru. And it had to be ordered from Japan! At least 2 weeks wait Sent from my iPhone using Tapatalk
  7. Are you willing to sell just the left side intake cam on its own? Sent from my iPhone using Tapatalk
  8. It's only the left hand intake cam that needs replacing. I'm not too keen on spending over 1k on a set of cams at this stage!
  9. Just an update. A new shortblock has been ordered and the heads have been sent away for service. They have found one of the intake cams to have weird wear on one of the lobes and recommends the cam to be replaced. Anyone know where to find a new or used Left hand intake cam? They also found the exhaust valves to be leaking and one of the lifter buckets has scoring marks on it. They think the bucket has been stuck and not able to move freely.
  10. Also here's a log from April 2017 after I had it tuned for 95 fuel. https://drive.google.com/file/d/1hqwZVpIjc25eiV-KmM8Lb6ikHwxpOEjG/view?usp=sharing
  11. Here's some pictures of the engine https://drive.google.com/file/d/1WX_tSGqM6GVtLin1mQ-bBPFWHA_APeGj/view?usp=sharing https://drive.google.com/file/d/11gP-tK_yd-DC5WP1Tfv7M9Hlw6v3SMwv/view?usp=sharing https://drive.google.com/file/d/1jCZcOIaVEEKSzoYUSMgGZ5fQPH2z6KII/view?usp=sharing The debris inside the bore was not there when the head was removed! It just from a dirty shop rag
  12. Yip that was the last log before the engine let go. Like I said previously the tuner looked over the log and couldn’t see anything dodgy. I have no reason to doubt his word. Sent from my iPhone using Tapatalk
  13. Hopefully this works https://drive.google.com/file/d/1ku-RVYtIO-ZquFECTK5GTVnBsBr36X0H/view?usp=drivesdk Sent from my iPhone using Tapatalk
  14. Hmmm I can paste the image link into the URL box but when I hit "Insert Into Post" nothing happens.
  15. I've got the log to post up but having trouble inserting the images. It's hosted on Flickr
  • Who's Online   0 Members, 0 Anonymous, 293 Guests (See full list)

    There are no registered users currently online