Jump to content
Please check your junk folder for registration emails ×

Search the Community

Showing results for tags ' speakers'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • General Vehicle Discussion
    • Stolen Vehicle Register
  • Knowledge Base
    • General FAQ (Read Only)
    • Model Specific Discussion
    • Non Model Specific Discussion
    • Legal
    • Motorsports
    • "Other" Tech Questions
    • Product and service reviews
  • Regions/Events
    • ClubSUB Events
    • Auckland/Northland
    • Waikato / Bay of Plenty / Taupo
    • Taranaki / Whanganui
    • Manawatu / Wairarapa / Hawkes Bay
    • Wellington / Kapiti
    • Nelson Bays/Marlborough
    • Canterbury
    • Otago / Southland
    • Outside NZ
  • Classifieds
    • Car Exchange
    • Parts Exchange
  • Forum Bugs / Errors and Suggestions and Test area
    • Bugs & Errors
    • Forum Suggestions

Product Groups

  • Subscriptions
  • CS Clothing
  • Stickers and Decals
  • Subaru Branded items
  • ClubSUB branded items
  • Limited Edition Items

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Drives :


Interests


Location


Occupation

Found 2 results

  1. Hey Club Sub members, greetings! As my first post I'd like to ask for some advice... Just as a preface, I'm great with IT & computers, cars and audio electrical, not so much... I've recently bought a 2006 Legacy Wagon (B-Sport 2ltr). Sadly, it came with the factory Kenwood head unit and factory speakers. I bought one of these yesterday and installed it without a hitch: http://www.jonvy.co.nz/index.php?route=product/product&product_id=4447&search=subaru It works really well. I generally just play music/podcasts from my phone, so it's perfect. I opened up one of the front doors next to check out the speakers. They're the horrible looking cardboard factory jobs. I have a couple of cheapish sets of 6" JVC speakers I've had sitting round for a while I want to install. I believe I need these: http://www.hyperdrive.co.nz/product/speaker-spacers/706/no905-universal-spacer-6/151234/detail , as the factory speakers have their own attached plastic spacer thingie. They also have the factory plug that connects to the cabling that goes back to the head unit. I have a couple of questions: - are those the correct spacers? They look to be the right size, shape to me. I'm guessing I may need to drill a couple more holes in them to fit the speakers perfectly. - How do I go about wiring the new speakers in to the plug currently in the vehicle. Does anyone know of a place that sells an adapter? As you can guess I'm not 100% confident in this, but I do want to learn. And I don't want to pay a car audio place to install when it doesn't appear to be that difficult. thanks!
  2. Hey guys, Seem to have blown a few of the speakers in the leggy, make popping noises at high volume. Assuming this is due to blown coils on the speakers not some other issue (???) whats the go on replacing the speakers with a full McIntosh system? Can i just put any speakers in there? Cant seem to find size/specs online anywhere does anyone have information about BP5 Mcintoshs? One of the speakers that's rooted is the sub, can i just replace that easy enough and use the factory amp? Any advice would be awesome! Cheers.
×
×
  • Create New...