Jump to content
Please check your junk folder for registration emails ×

Search the Community

Showing results for tags 'impresza'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • General Vehicle Discussion
    • Stolen Vehicle Register
  • Knowledge Base
    • General FAQ (Read Only)
    • Model Specific Discussion
    • Non Model Specific Discussion
    • Legal
    • Motorsports
    • "Other" Tech Questions
    • Product and service reviews
  • Regions/Events
    • ClubSUB Events
    • Auckland/Northland
    • Waikato / Bay of Plenty / Taupo
    • Taranaki / Whanganui
    • Manawatu / Wairarapa / Hawkes Bay
    • Wellington / Kapiti
    • Nelson Bays/Marlborough
    • Canterbury
    • Otago / Southland
    • Outside NZ
  • Classifieds
    • Car Exchange
    • Parts Exchange
  • Forum Bugs / Errors and Suggestions and Test area
    • Bugs & Errors
    • Forum Suggestions

Product Groups

  • Subscriptions
  • CS Clothing
  • Stickers and Decals
  • Subaru Branded items
  • ClubSUB branded items
  • Limited Edition Items

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Drives :


Interests


Location


Occupation

Found 1 result

  1. Hi team, Started car from cold this morning and got to the first set of traffic lights. Noticed car was idling at 1500rpm which is a little unusual for my car (it usually hits warm idle very quickly). Drove about another 1km to my destination, stopped car for 10min (and turned off), started car and drove to next traffic light - rev meter fluctuating between 500 and 2000rpm and can't settle on a number. Engine check light came on. Drove 20km to destination (motorway) and 1km before destination the engine check light went off. When I reached my destination I let the car idle for 30secs. Revs at 500rpm the slowly climbed to 800rpm over 10 seconds. Vehicle is 1997 WRX STI. Is this my o2 sensor? Thanks in advance for any help or advice.
×
×
  • Create New...