Jump to content
Please check your junk folder for registration emails ×

Shimmy

General Member
  • Posts

    5
  • Joined

  • Last visited

Everything posted by Shimmy

  1. Sorry if the answer is somewhere on these forums already but I couldn't find it. I have a Manual BP Legacy and need new from shock assemblies. What model shocks will fit? BH5 Legacy? BHE Legacy? Even BG? (But I imagine not). Hope someone has the answers or the link to where I can find this info. Thanks,
  2. Straight to the point: No CEL on just vehicle running very rough especially at idle it would nearly die. Cold or hot just ran like crap. When driving at higher revs it was nearly impossible to notice anything wrong. Read on and you will see why. Scanned the ECU using Launch scanner and nothing. Read on here about these stupid AVCS Filters located in the Bango bolt oil feeds to the Left and Right Bank AVCS solenoids. Very simple to reach each bango bolt from above (17mm socket) and check the filters. The right one had begun falling apart but the left one was munted.Then removed the left AVCS solenoid. Again simple just a 10mm bolt. Sure enough a piece of the filter was jammed in the solenoid holding the solenoid piston in the advanced position (see photo). You can see the mark on the piston where it normally sits when resting. Simply pried the piston back carefully and removed the piece of plastic. Put the solenoid back in and happy days all fixed. Stupid little problem that could leave alot of people running in circles checking spark plugs etc when this is a far easier check. I had tried checking the Solenoid Positions live data with the Launch scanner before pulling things apart but sadly the scanner could not show me this data. I really hope this helps someone.
×
×
  • Create New...