Jump to content
Please check your junk folder for registration emails ×

Nick89

General Member
  • Posts

    31
  • Joined

  • Last visited

Personal Information

  • Drives :
    Subaru

Nick89's Achievements

Restricted License

Restricted License (2/7)

10

Reputation

  1. GF8 impreza. Anyone else's windscreen wipers BASH back into their little seating bits on the downward stroke? On the fastest setting, its like someone hitting the valance panel with a hammer! Bloody noisy. Just wondering if everyone else's does it or is something crook with my wipers somehow??
  2. Ah no ****??! The subaru service guy! Howdy! Yeah, I guess it's only worth doing if the car is really gummed up from short trips and all that, which I can see it making a difference.
  3. Yeah I ran some injector cleaner through it a few months back before a long trip. I did an oil change the same time I did the upper cylinder cleaner. I know it shouldn't matter, but it just felt good to give it a wicked service! Upper cylinder cleaner, oil change and filter, new plugs, and with my recently rebuilt front calipers...its like a new car. Still slow though......
  4. Just ran some through. Not a lick of difference! And no smoke whatsoever either! Was a bit disappointing actually haha. And yes, I did spray it in the right place. I guess since my car sees almost entirely motorway running, there isn't much of a chance for carbon and other gunk to build up like in city driving.
  5. Hey all. Im about to do a service on my 1998 subaru impreza, non turbo two litre. I figured I'd run some of that upper cylinder cleaner through it, since I havent done it in the 20,000 or so kays ive had it, and i doubt the previous owners did either. The service department guy at Subaru warned me that it could damage some of the seals within the engine if it hasn't been done before. Car has done 158,000 kays. Im sure he's just being cautious, and I can't see it buggering anything, but I'd hate to do it and then....I dunno....wreck a valve steam seal or anything. Soooo......go for it? Or leave it alone? As I said, he's probably legally obliged to warn me of it, but he said it is part of subarus service plan and should be done every 10,000 kay service anyhow. So yeah, advice?
  6. Problem solved! It did turn out to be a seized caliper. Front left. Looks like a classic case of water in the brake fluid. Obviously the previous owners never thought to change it. My old mans mate who is doing the job said it was the second worst seized caliper he's ever dealt with! Hard case. Easy fix, cheers for the feedback.
  7. 3000km is quite low! I've always done oil and filter at 5000km for anything turbocharged.
  8. Yep, I pretty certain the caliper is seized. No movement in it whatsoever, even with a g-clamp. Whats the fix? Is it a new seal kit or something? And is it something I can do myself or do I have to fork out for an expert?
  9. Sounds possible, but there was no movement in the wheel when I gave it the wriggle test. I've just had the caliper off, which was tight, and the brake piston is REALLY hard to squash back in. Ive got a g-clamp on it, and it doesn't want to budge. Even with the bleed nipple open a fraction its still solid as. Possibly seized caliper? I'll keep on skinning my knuckles, throwing tools and swearing heaps, and get back to you with any progress! Cheers for the feedback guys.
  10. Had the front wheels of this morning. Rotors turn freely by hand, or as freely as they should. Front left CV boot is torn. Not making any knocking noises so I doubt the CV joint is buggered. Took my old man for a drive this morning, he's an ex motor mechanic so he has at least half a clue. Drove for about 10 minutes around suburbia without any issues. After 10 minutes, the shaking reappeared, and got progressively worse. It was again accompanied by the dragging feeling when coasting. Went for a short trip down the motorway, still shuddering, and off an off ramp. Shuddering to a halt at the bottom of the off ramp, we waited for the lights to go green, and when taking off, it was completely shudder free from then on all the way home. Bizarre. It almost feels as if something is out of round?? I'm not sure if its brakes binding up, as it doesn't pull to one side under braking. Unless its both front brakes binding evenly?? Then again, theres no vibration or pulsing through the brake pedal either....so I'm fairly certain its not brakes. I'll keep tinkering and let you know what I find....
  11. Possibly, but that wouldn't explain the 'drag' felt when cruising along? I'll definitely check it out though, I got the front of it up on axle stands at the moment, and I'm gonna have a poke around today.
  12. Hi all. On a recent trip back from up North, I started feeling a bit of a shudder in my Impreza. Its a 1998 2 liter auto naturally aspirated rocket ship. I could feel it through the steering wheel, and got worse as I braked / slowed down. Naturally I pulled over to the side of the road, and had a look at my tires. In the past, I've had a similar issue with the steel belts in the tires breaking and the tire getting a bulge in it (****ing potholes). But the tires were fine, and all my wheel nuts were on tight. So I carried on.....and the wobble had gone! A few kilometers later, after doing some braking, its started happening again. And it carried on like this the whole way home.....would shudder for a bit, then clear up. When I got home, I unpacked all my gear, and went for a few laps around the block. Same issue. Would be fine for a bit, then start shuddering. But this time, I noticed the car slowing down...almost like I'd yanked the handbrake up a few notches. I really had to put my foot into it to get it to go! So what do you experts reckon? Im a bit basic when it comes to diagnosing, but I can fix most things myself. CV joint? Wheel bearing? Something more terminal? If anyone has had this issue before, or could point me in the right direction, that'd be much appreciated. Cheers.
  13. Ah true that could be the go! Nah I was just wondering about them, would be a cool car for my 'one day' garage.
  14. Hi all. I was wondering about those 4th gen outback wagons. BPE chassis code i think? Did the outback come with a 3.0 flat six and a manual gearbox? Because that would be a wicked daily, in terms of usefulness and all that. I know the legacy wagons came 3.0 manual, not sure about the outbacks. Anyone know? Cheers.
  • Who's Online   0 Members, 0 Anonymous, 15 Guests (See full list)

    There are no registered users currently online

×
×
  • Create New...