Sign in to follow this  
dirtysouth

clutch thud

Recommended Posts

I'm not the most mechanical of people but I've noticed a thud whenever I release the clutch while moving. It won't happen when braking or accelerating. I had the transmission mount replaced the other week any ideas before I take it to the garage for a look.

Share this post


Link to post
Share on other sites

Is the thud coming from under the gear lever? Or further towards the rear of the vehicle? 

 

You said it won't happen when braking or accelerating. Are you releasing the clutch with no throttle input when it happens then?

 

 

  • Like 1

Share this post


Link to post
Share on other sites

I'd be checking engine mounts, engine stay (the dogbone from top of block to the firewall) and rear diff bushes.

 

For the first two -- rev the engine in neutral and see if it moves around too much.  For the rear diff bushes, crawl under the car and have a peek - they're pretty obvious when gone.

Edited by duncanm
  • Like 1

Share this post


Link to post
Share on other sites
On 17/05/2017 at 7:50 PM, IZichard said:

Is the thud coming from under the gear lever? Or further towards the rear of the vehicle? 

 

You said it won't happen when braking or accelerating. Are you releasing the clutch with no throttle input when it happens then?

 

 

Went for a drive today sound like it's at the front of the engine at very least engine bay. Sorry I was meaning it won't happen if I plant my foot on the accelerator or brake. Releasing the clutch with or without throttle give the same noise. Think I will grab one of the guys for the garage and go for a lap of the block. Thanks for the help

On 18/05/2017 at 1:04 AM, duncanm said:

I'd be checking engine mounts, engine stay (the dogbone from top of block to the firewall) and rear diff bushes.

 

For the first two -- rev the engine in neutral and see if it moves around too much.  For the rear diff bushes, crawl under the car and have a peek - they're pretty obvious when gone.

 

Engine stay feels pretty solid and doesn't seem to move much. Shitty weather and no garage wasn't so keen to crawl under the car. Thanks for a starting point 

Edited by dirtysouth

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this