Jump to content
Please check your junk folder for registration emails ×

Walbro install into My BG5 Legacy


Joker
 Share

Recommended Posts

  • General Member

nb : NOT a DIY more a "how I did it"

took me two hours

http://smg.photobucket.com/albums/v427/JoKerNZ/2012/Walbro%20install/

so at 40km shy of 230,000 pump dies on an intersection going to work :/

Step 1 : Identify fault = Pump no go, was getting power, no sound!

Step 2 : Email Brendon @ GFB (see sponsors section) recieve 500 HP pump overnight with fitting kit

Step 3 : Locate pump, under boot floor between rear struts, remove hatch and screws,carefully pull assembly out (after lableing lines)

Walbro012.jpg

Walbro013.jpg

Walbro015.jpg

New and old parts

Walbro018.jpg

Walbro019.jpg

Filter Sock old

Walbro022.jpg

Walbro023.jpg

Above is the new pump isolator and below comparison , need to do some trimming with knife

Walbro025.jpg

Walbro032.jpg

New vs old

Marked for trimming

Walbro035.jpg

Walbro038.jpg

Above : it fits nice and snug now

Below small hiccup with wiring harness supplied about 4mm too short

Walbro040.jpg

Walbro042.jpg

Solution cut and crimp wires

below yay no spare parts!

Walbro043.jpg

Symptoms of pump dying were slow to start/fire then the obvious failure

all happy now :P

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...