Jump to content
Please check your junk folder for registration emails ×
  • Current Donation Goals

    • Raised $0.00

Help! Help! Hose 10 Modification on MY1999 GF-BE5


dunky

Recommended Posts

Hello guys,

I read all about Hose 10 Mod threads on Legacy Twin Turbo and I was eager to implement the hose 10 mod on my 1999 GF-BE5 (BE5A48T). So, I did exactly that. What I noticed:

1. Boost is good at lower rev range and it was really fun, however, I only got 0.4bar = 8psi on primary.

2. But boost tend to drop soft at higher rev range, looks like secondary Turbo not kicking after the mode.

 

I noticed, there is also another T piece (as encircled red in attached image) connecting three lines: hose 10 that goes into a metal piece (encircled yellow) and another hose 10 which comes from behind the battery side and then to third hose that comes from Turbo intake beneath as shown.

The blue hose is the one I have disconnected and blocked from first T between BOV and intake Manifold then ran straight grey hose as highlighted green.

 

How do we handle the second T piece? Could it be the one making me not achieve the best end result?

DWf8yph.jpg?1

 

 

Edited by dunky
Inserting image link
Link to comment
Share on other sites

Hey mate,  its often hard to explain as people interpret things differently. However! here goes. From your image it looks like you have half completed the mod. 

 

basically remove the hose that goes between the two T's and block off both T's 

 

This page is also helpful, but its done on a Rev-D so pictures may look different than your engine bay https://www.tasteslikepetrol.net/2017/01/s401-hose-10-mod/

 

 

Its also worth mentioning that someone may have already played around in your engine bay so dont think its already plumbed correctly. Get a diagram up and go through it to make sure its all ok 

 

 

Link to comment
Share on other sites

On 4/10/2019 at 12:34 AM, A_J_T said:

Hey mate,  its often hard to explain as people interpret things differently. However! here goes. From your image it looks like you have half completed the mod. 

 

basically remove the hose that goes between the two T's and block off both T's 

 

This page is also helpful, but its done on a Rev-D so pictures may look different than your engine bay https://www.tasteslikepetrol.net/2017/01/s401-hose-10-mod/

 

 

Its also worth mentioning that someone may have already played around in your engine bay so dont think its already plumbed correctly. Get a diagram up and go through it to make sure its all ok 

 

 

Hey, Buddy

Thanks a lot for the reply. By the way, see below diagram: The part confusing me is how to handle the line 10 which runs as per green line drawn herein. It runs from manifold to BBoD then from BBoD, it terminates on a metal line (bleed/recirc for the ECV duty solenoid (coming from BBOD)) which then get connected to the line 10 coming from behind the battery (bleed/recirc from the primary boost solenoid (coming from behind battery)) through a T piece (yellow encircle) and finally terminates to the pre-turbo intake.

 

Should I do below three steps ?

==========================

1. Run a straight hose from BOV to intake manifold (block first T piece).

2. Connect bleed/recirc from the primary boost solenoid (coming from behind battery) directly to pre-turbo intake.

2. Block the line for bleed/recirc for the ECV duty solenoid (coming from BBOD) ? fnZkzab.jpg

 

Edited by dunky
Inserting image link
Link to comment
Share on other sites

Hi, A_J_T

By the way, I solved the issue. Actually, the metal pipe with hose 10 (bleed/recirc for the ECV duty solenoid (coming from BBOD)) should not be blocked but instead it should be the one going straight to the Pre-turbo intake then the hose 10 from behind the battery (bleed/recirc from the primary boost solenoid) should Tee on it.  I think that is the secret and now my primary turbo is boosting at 0.8bar and secondary turbo is boosting at 1.1bar. With upgraded fuel pump to Walbro 340 LPH, now am planning to install water-methanol injection kit with AEM X-Series UEGO 30-0300 wideband 4.9LSU next week then dyno-tune with ECUTek  in order to achieve 1.3 bar = 18.9 PSI safely (Project Car (pics attached)).

 

7A8Bdfh.jpg

 

Below is Hose 10 Mod reference diagram: Courtesy of a member from UK Legacy Forum.

G6TuFxx.jpg

 

Below is my car - 1999 GF-BE5 Twin Turbo attending African Rally Championship  (Pearl Of Africa Uganda Rally)

VaQ2iuz.jpg?1

k14QjmA.jpg

 

Subaru Owner's Club Uganda (Underground Legends)

zvUwXEN.jpg

 

Edited by dunky
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recent Status Updates

    • MrSg9Sti04

      Afternoon team,
      im new to the group first time posting. Im hoping some body can help me get my launch control all dialled in on my link g4x. Ive had the computer and car all tuned from chris at prestige awesome knowlegable guy super happy with the results but now im wanting to get my launch/anti lag all dialled in. Ive been reading multiple different forums etc all with different conflicking information which has made me nervious with what do i listen to this or that if you get what i mean. Now ive started to make myself familiar with my PClink software etc the past few weeks and im eager to learn how to do minor setups or tweaks etc so im not relieing on my tuner so much and obviously saving myself abit hurt in the back pocket. 
      Now back to the question at hand.... Im wondering if theres and one who could please share there knowledge and wisdom with setting all my values, timing, fuel etc when i have launch control armed and engaged, or even a launch tune file they can possibly send me to load onto my tune. Ive figured out the setup of my digital inputs turning launch control on etc and its obvisously on its pre set factory settings. It engages but doesnt sound the greatest or as angry as it should i feel. Hence reaching out to you good buggers. 
       
      Cheers in advance for any info and help yous maybe able to give me.
       
      Cheers Shaun
      · 0 replies
    • Joker  »  gotasuby

      updated your DP's too : hope that's ok!
      · 0 replies
    • Joker  »  SAS

      Updated your DP's to reflect your business page  
      · 0 replies
    • Joker  »  Nachoooo

      Updated your Avatar : couldnt help myself  cheers!
      · 0 replies
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    40.9k
    Total Topics
    573.6k
    Total Posts


×
×
  • Create New...