Jump to content
Please check your junk folder for registration emails ×

Help! Detonation!


snowflake009
 Share

Recommended Posts

I had my bp  legacy in for a tune the other day at Dtech and they can't put timing in as it detonated like a b**ch. Mods is upgraded turbo. Fmic. Intake. Fuel pump. Decap injectors and full exhaust inc headers and up pipe. They done a back pressure test and that checked out ok. My boost gauge is tapped off the fpr reg vac line so will change that and Chuck in some colder plugs. Has anyone had this problem or could point me in the right direction as where to start looking? 

Link to comment
Share on other sites

  • Admin

Been thinking about this after talking to Tony, surely the most logical issue is the decapped injectors putting out a F***ed up spray pattern and not atomising the fuel very well. Sounds like they exhausted most other trains of thought. Did they only just get done when you had it at DTech?

 

Tony reckoned it was detonating like it was filled with 91 but had been filled with BP98 just round the corner correct?

Link to comment
Share on other sites

Yeah has 98 from bp tauriko. Decaps crossed my mind too but i trust they done a good job. They done them there before the tune. 

20 minutes ago, evowrx said:

Running 98? Any history on an engine rebuild or timing change? How new were the plugs?

Egbp test pre and post turbo?

Engine hasn't been rebuilt as far as I'm aware and timing belt with all the bits n pieces was done about 30000kms ago. Back pressure test was before turbo. Plugs are about a year old ngk ir6b's. Will check them out and do a compression and leakdown test in the next week just to be sure but last time it all checked out ok. Is there any way to check the afm without a scan tool as I was told a faulty one could affect timing as well as the obvious afr

Link to comment
Share on other sites

Wouldnt have thought it would be maf. If it was lean causing det that would be obvious with the wideband vs tune. Worth trying another in there but your fuelling tables would be way off compared to what one would expect for power/airflow if that were the issue.

Link to comment
Share on other sites

28 minutes ago, BC5RA said:

I'd go grab a genuine air filter and some CRC afm cleaner and give it a spray.

Will give it a clean tho can't go factory air filter with intercooler piping in the way. 

 

9 minutes ago, evowrx said:

Wouldnt have thought it would be maf. If it was lean causing det that would be obvious with the wideband vs tune. Worth trying another in there but your fuelling tables would be way off compared to what one would expect for power/airflow if that were the issue.

Tho if there was a delay in the reading it could lean out enough to det and not pick up on the wideband. After det it retards the timing so would be hard to pick up. Just an idea anyway. 

Link to comment
Share on other sites

29 minutes ago, Andy_Mac said:

Yea can give it a go in mine. Don't really think it's the issue though. AFR's are sweet so can't see it being the issue. 

You know when it starts detonating? Above a certain RPM?

Cool thanks. Will give you a txt. Just want to eliminate it as a problem as I don't have a way of testing it. They said anything over 150kw. Not sure about revs etc

 

14 minutes ago, evowrx said:

Post up pics of the engine bay and dyno graph if you can/want to. Could help but more just to satisfy my curiousity.

Haha yeah I will do shortly

Link to comment
Share on other sites

  • Admin

Went and did another couple of logs with my MAF back in and it cut out at the same point so it's definately an issue with my car rather than the MAF. I know my battery is stuffed and have heard of that causing RomRaider to play up at WOT so probably just a result of that. 

The readings from yours were basically identical to mine up till it cut at ~3900rpm each time.

Link to comment
Share on other sites

5 minutes ago, Andy_Mac said:

Went and did another couple of logs with my MAF back in and it cut out at the same point so it's definately an issue with my car rather than the MAF. I know my battery is stuffed and have heard of that causing RomRaider to play up at WOT so probably just a result of that. 

The readings from yours were basically identical to mine up till it cut at ~3900rpm each time.

Thats good to know. just out of curiosity whats a set of bigger side fed injectors worth and where to get them from?

Link to comment
Share on other sites

4 minutes ago, evowrx said:

Not to play the dickhead but I would wonder if its had an n/a block put in it or the timings off. 

how would i tell if its a n/a block or not? without stripping the motor of course. checking the timing marks is on my to do list.

Link to comment
Share on other sites

  • Admin
12 minutes ago, evowrx said:

Not to play the dickhead but I would wonder if its had an n/a block put in it or the timings off. 

 

Would a higher comp N/A block not give a considerably higher figure with a compression tester?

Link to comment
Share on other sites

  • Admin
8 hours ago, Marky said:

Does it actually need bigger squirters at this stage? 

 

Have you done a pressure test on the whole intake? 

 

Have you checked fuel pressure once it comes on boost (fuel pump or reg being sad?)

 

 

The tuner would pick that up; it would show in the AFRs.

 

"random" knock is a really hard one to pin down; pretty long list of possible causes.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...