Sign in to follow this  
Joe

Unequal length headers

Recommended Posts

Has anyone put UEL headers on a non turbo ej20 legacy. can it be done And what work would need to be done if any.  

Share this post


Link to post
Share on other sites

You will have to have a pipe made to match up the UEL headers to the NA exhaust as they are completely different.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Joe
      Was looking at getting some shocks and springs for my car and  found some bilstein shocks and lowering springs from a BP5 and he was running 18x8.5 215/40 will I run into any issues if I put them on a BL5 running 18x9 225/40
    • By spuddling aka IMPRZF
      Evening all,
      Have recently brought a 2012 BM GT S Legacy, black, leather, full STi exhaust, 2.5 turbo and best of all 6 speed manual.
      Its a amazing car to drive, however the speedo, fuel consumption gauge and odometer has recently stopped working.
      Cruise control still works as normal.
      Wondering if anyone has had the same or similar experience and what may have caused the issue.
      Have checked to see any broken or loose cables, sensors etc but to no avail. The newer Subaru’s are a bit more fancy than the old STi parked beside it in the shed!
      Any suggestions greatly appreciated as the nearest Subaru dealer is somewhat of a drive away, we are located in Fiordland.
       
    • By Rickit
      Gidday people, I have a 2006 legacy Gtb auto gen 4, all stock, was driving long distance today and after 1hr 10mins I got a beep and a message in Japanese on the instrument cluster info part, and then again later on,any idea what this is, car still ran fine, cheers
  • Recent Status Updates

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Forum Statistics

    39,888
    Total Topics
    566,729
    Total Posts