Sign in to follow this  
funkytown

My sad STi..

whats your money on being wrong with my wagon  

42 members have voted

  1. 1. whats your money on being wrong with my wagon

    • running WRX heads, not STI
    • bung block - head gasket
    • Bung block - valves are screwwy
      0
    • Dead Turbo
    • i have gremlins and they stole my ponies
    • Poos tune or somehow the driver doesnt have mental capacity to squeeze the throttle right to the floor
    • other - post up what you think


Recommended Posts

You know the car, has a few mods and running 18psi - only pulled 160kw, car seems fine to drive though...

based on other similar mods and car it should do about 200kw

POLL on!

oh - and its being diagnosed Friday so I should have some answers by then

Share this post


Link to post
Share on other sites

I note there is no option for just a pi$$ poor tune...

Nor one for the driver... lol

Share this post


Link to post
Share on other sites
Guest iceboychch

" yo G, that wagz is phat ass mayne, sup with yo turbz bra? sounds mean az! do you reckon i can get my rolla banging hard on all fours? bro unhook that tube there bro you will booost hard and do some mean az drifts"

not my advice but the type ya'd get from a certain group down here.. and yes they are still causing shite!

im betting on the turbo!

Share this post


Link to post
Share on other sites
 loud_As said:

I may have a vf23 sitting at home ;)

If its borked i have plans to be quite different ;) lol sorry. your other one has gone way to far anyway, i would be looking brand spankers at this stage

Share this post


Link to post
Share on other sites

My guess would be posting Tech in the Wellington section.

Maybe you put oil in your radiator as well, or diesel in your petrol tank, or maybe a vodka enema (all things being put where they probably shouldn't be)

But realistically, anything that anyone would guess would be just that, i guess, so i guess that your car has herpes, i hope it didn't give it to mine when they pashed in the garage.

Share this post


Link to post
Share on other sites
 TURTLE said:

My guess would be posting Tech in the Wellington section.

Maybe you put oil in your radiator as well, or diesel in your petrol tank, or maybe a vodka enema (all things being put where they probably shouldn't be)

But realistically, anything that anyone would guess would be just that, i guess, so i guess that your car has herpes, i hope it didn't give it to mine when they pashed in the garage.

Im just after guesses - before i find out. This is not meant to be a trouble shooting technical thread. just money down for what people think.

hmm me thinks maybe yours have mine herpies after pashing - as it ran worse after

Share this post


Link to post
Share on other sites
Guest Oscar
 loud_As said:

I may have a vf23 sitting at home ;)

You still have it!?

There is hope for me afterall! No wait...can't do anything till June >:(

Share this post


Link to post
Share on other sites

am I allowed to have 2 guesses?

I saw a decent puss of purple smoke twice after you'd been on the track and restarted the car after it had cooled down a bit.

1. Turbo about to die, maybe seals starting to leak

2. Too much oil in your intercooler and intake.

Might be an easy option just to degrease the intercooler, it cant hurt!

Share this post


Link to post
Share on other sites
Guest

i pulled 176kw on 15psi so yeah and done bugger all mods. U should have pulled more i wouldnt have a clue whats wrong with your car. :P No help at all ay.

Share this post


Link to post
Share on other sites

I got a VF8... best thing you could do for it... chuck it in yo and convert IC to air to water...

Should be good up to about 380kw at the exhaust pipe bro!!!

Face it... only one way to go in the figures aye... lol sorry also no help... My black wrx pulled 190 with grey injectors and factory ecu.

Share this post


Link to post
Share on other sites
Guest SPANKU

either poked turbo, bad compressions or a bad tune. what duty cycle was the injectors on? 550cc should easily get u 220kw if tune right?

my car feels like 160kw at 15psi. since ive put my extractors on it dont feel as fast as with the standard manifold.

wait to see what rick say after the compression test. i didnt have a good look at your motor to see if its been rebuild or not

Share this post


Link to post
Share on other sites
Guest
 SPANKU said:

either poked turbo, bad compressions or a bad tune. what duty cycle was the injectors on? 550cc should easily get u 220kw if tune right?

my car feels like 160kw at 15psi. since ive put my extractors on it dont feel as fast as with the standard manifold.

wait to see what rick say after the compression test. i didnt have a good look at your motor to see if its been rebuild or not

With extractors you need to have them wrapped. Even then they will not work as well as std headers till they have warmed up. The stock headers being cast iron retain heat much better than SS.

Share this post


Link to post
Share on other sites

think we found the problem.. and im off to buy a lotto ticket...

how i didnt have a completely ka-boomied engine is a miracle.

Share this post


Link to post
Share on other sites
 funkytown']

[quote name='Odie said:

you had a loose connection on the injectors huh...

/quote]

nup

comon tell us??

Share this post


Link to post
Share on other sites

ok, so my crank is split in two - everyone happy now..

block is coming out and think il be selling the car off

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this