Jump to content
Please check your junk folder for registration emails ×
  • Current Donation Goals

    • Raised $0.00

Turbos on Twin Turbo Subaru Legacy/s


gtlegacy

Recommended Posts

hey all

well well well i fitted rage downpipes and you knw whats happened

i boosted in 4th to pass a car and when it switched over about 4700-5000 it made a funny like whiney but boosting noise for about 2 seconds and stopped and it hanst done it again now i have noticed water dripping from the joins where the gaskets are on my primary turbo side? at downpipe to y join and y to centre pipe

anyways its only a few drips is it a real big deal? its not making any noises and seems to boost fine (although it has dropped slowly over about 5000km ) maybe 1psi-1.5ps maybe just the heat

im really just after a second opinion as far as i can tell there is no noise coming from the turbo at idle or when im drving it also no smoke and no oil dripping through the join where the water was

maybe time to try vf31 with vf20 back :P ;D

Link to comment
Share on other sites

LIFTED FROM ANOTHER FORUM

The PowerEnterprise turbos:

PE1016F = VF32 or VF31 on a P16 (A/R 16) turbine housing configured as a primary turbo

This is the most powerful BB primary turbo available.

PE1018F = VF32

Using what is available from all the twin turbos IHI/Subaru put together.

Maximum optimization of TT turbos suitable for 2.5L

Use the 2 x VF14 CHRA both of these are hiflowed with 41.3/56mm (5/5) compressor wheel

The primary turbo will use the compressor cover and the turbine housing (A/R16) from the a VF13

The secondary use original VF14 compressor cover and a turbine housing (A/R 18) from ie VF32,VF27

These turbine housing are then machined to take the larger exducer (39mm) VF14 turbine wheel.

The waste gate on the VF13 is ported with a larger flapper and will use the VF14 actuator.

If your original primary turbo was a VF33, to match the inducer we put on a 60mm valley collar on the VF13 compressor cover.

These twin BB turbos will have maxed out compressor wheels and use the largest turbine wheels/turbine housings available.

From here all you can use is TD04s and that can be done too! But they will not be BB

maybe something else to look into

guy was after twin turbo sequential set up bigger to suit a 2.5

also noticed that one of the techs on ozliberty.com had 229kws atw holy far k

Link to comment
Share on other sites

I have spoken to Dave @ total turbo and he's going to port out the wastegate on my primary. Also gonna have a chat to him about other options as it sounds like he's done a few of these before. He said something about an actuator mod.. will have a good chat to him when i drop the turbos off.

I'll hopefully pull the turbos this weekend. anything i need to know? any need to drain coolant/oil first? or is it ok to just bung the lines etc?

While the turbos are off the car, gonna sort out some downpipes and y pipe. Any recommendations for retailers in welly? If not i'll just get rage to send some up.

Link to comment
Share on other sites

the rage downpipes are not to bad i didnt notice a huge change but definetly spooled up earlier but maybe it was because i allready had earlier spool from my prova ecu also changes the engine note to a bit more aggressive sounding they are probably the best and cheapest option if you dont have many skills to make your own

Link to comment
Share on other sites

  • 1 month later...

Turbos are finally on the car and after a fair amount of head scratching its running with no oil or air leaks.

Boost is far more progressive with this combo than with the vf18/19. The car launches much, much harder and dosent bog down like it used to.

Over a given stretch of road (100m?) I'm picking up an extra 15km/h over the old combo. (primary only - shortshifting before vod)

I've also found that the new primary's sweet spot is later in the rev range than the vf18, which means i've had to change my sequential controller settings.

VOD has also been reduced further.

1 thing though, and thats that i'm not getting the same punch on secondary that i was - Possibly because along the way some of the vacum hoses connecting to the secondary actuator got munted and have been rangied up. will replace these when i find some and see how i go.

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

quoted from telemekas

"From the VF33 you just need the turbine housing and the wastegate actuator.

The turbine housing will need to be scrolled out or high flowed to take the larger TD04L wheel. Once that is done put the TD04L CHRA onto it and orientate the the original position as the VF33 was in . Install the actuator.

Have the wastegate ported within tolerance of the existing flapper or ideally a larger porting with new bigger flapper"

so does this mean that the front is td04 and the back is td04 just with a smaller housing? to spool it up faster than a standard td04?

Link to comment
Share on other sites

hey guys....i need to upgrade mi turbo comboz...

i got 1998 rs manual BD5C currenty on vf 18/19. can somebody assist me which upgrade be da best...

i like RSB's upgrade to vf 31 (18) and vf 32...is that a best upgrade or it cld be mre better...

and is there is any one in auckland who can do the job for me...

Link to comment
Share on other sites

Not to hassle you but those that know on here take you a lot more seriously if you don't use txt-speak.

There a few threads on here asking the same question as you've asked and the vf26/27 is regarded as the best of the range.

As to fitting issues I believe this was covered in those threads...

cheers

Link to comment
Share on other sites

  • 2 weeks later...

hey guys im new to subies and this forum. ive got a bg5 twin turbo wagon. as far as i know my second turbo is blown. once 4000rpm it stops boosting etc. i took my passenger side turbo out today and im in the process of installing a vf14 instead of the vf13 factory. this may sound nood but have i taken out the secondary turbo? im replacing the primary aswellwith a vf14 just wondering which is which and if anyone has any pointers.

cheers

Link to comment
Share on other sites

hmm replaced my secondary turbo the other day with just the standard vf14. it boosts now. but there is a point between the turbos when boost cuts out. anyone know if is this common?

also when i am thrashing it it has recently been cutting out all together past 3000rpm and check engine light comes up. i turn the car off and it goes away, for a bit but if i boost hard it just happns again.

grrr has this happend to anyone else? needa fix it

Link to comment
Share on other sites

yes its vf13 primary. my m8 took the recirulating hose off and blocked up the hole it goes into. it made the blowoff valve noise but i changed it back to sttandard because this started happening. but its still doing it

hmmm

Link to comment
Share on other sites

  • 2 weeks later...
 bg5dave said:

hmm replaced my secondary turbo the other day with just the standard vf14. it boosts now. but there is a point between the turbos when boost cuts out. anyone know if is this common?

also when i am thrashing it it has recently been cutting out all together past 3000rpm and check engine light comes up. i turn the car off and it goes away, for a bit but if i boost hard it just happns again.

grrr has this happend to anyone else? needa fix it

i think thats vod (valley of death), just the lag when the secondary turbo's spooling.

thats an odd problem you're having....

double check all the valves and piping and seals, gaskets etc.

Link to comment
Share on other sites

  • 2 weeks later...

i dont know whats going on. i checked all the vaccuum lines etc the theyre sweet and going where they should be. the pipe going from the intercooler to the intake is a little bit rugged but im sure its still sealing.maybe its something to do with the turbo/s themself?

Also how do i check the CEL code? i dont have a tool for this

Link to comment
Share on other sites

ok ive checked it. its CEL 66 - sequential twin turbo system. go figure. anyone had this before when theyve changed their turbos?

Link to comment
Share on other sites

 

hey guys im new to subies and this forum. ive got a bg5 twin turbo wagon. as far as i know my second turbo is blown. once 4000rpm it stops boosting etc. i took my passenger side turbo out today and im in the process of installing a vf14 instead of the vf13 factory. this may sound nood but have i taken out the secondary turbo? im replacing the primary aswellwith a vf14 just wondering which is which and if anyone has any pointers.

cheers.

 

hmm replaced my secondary turbo the other day with just the standard vf14

 
yes its vf13 primary.

So to clarify:

You took the Passenger side turbo out (Primary), started putting in a vf14, stopped, put back the VF13, then took off the secondary turbo (Drivers side) and replaced it with another, stock VF14?

Link to comment
Share on other sites

sorry i replaced the secdonary with a vf13 and just took the exhaust housing off the primary and put it back together, then put it back in. it boosts now but under load it will cut out and engine check will come up

Link to comment
Share on other sites

  • 2 weeks later...

hey guyz sorry to interupt but is this common when i get on the secondary my boost goes up and at about 6000rpm drops back about 5psi it does it when my boost set at 20(yes i know that high) drops to 15 and when it set at 15 drops to 10 is that not weird? or is my wastegate blowing open as i get higher up the rpm? how do i fix? lol

Link to comment
Share on other sites

also that seems alittle wierd is there anything different about the vf13 and 14 ? they both have wastegates so essentially shouldnt it work? but it would have a good primary and not so good secondary stage as the larger turbo would be coming in first

also what was your reason for changing the housings over because from how i see it the vf13 and vf 14 have different size wheels

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recent Status Updates

    • MrSg9Sti04

      Afternoon team,
      im new to the group first time posting. Im hoping some body can help me get my launch control all dialled in on my link g4x. Ive had the computer and car all tuned from chris at prestige awesome knowlegable guy super happy with the results but now im wanting to get my launch/anti lag all dialled in. Ive been reading multiple different forums etc all with different conflicking information which has made me nervious with what do i listen to this or that if you get what i mean. Now ive started to make myself familiar with my PClink software etc the past few weeks and im eager to learn how to do minor setups or tweaks etc so im not relieing on my tuner so much and obviously saving myself abit hurt in the back pocket. 
      Now back to the question at hand.... Im wondering if theres and one who could please share there knowledge and wisdom with setting all my values, timing, fuel etc when i have launch control armed and engaged, or even a launch tune file they can possibly send me to load onto my tune. Ive figured out the setup of my digital inputs turning launch control on etc and its obvisously on its pre set factory settings. It engages but doesnt sound the greatest or as angry as it should i feel. Hence reaching out to you good buggers. 
       
      Cheers in advance for any info and help yous maybe able to give me.
       
      Cheers Shaun
      · 0 replies
    • Joker  »  gotasuby

      updated your DP's too : hope that's ok!
      · 0 replies
    • Joker  »  SAS

      Updated your DP's to reflect your business page  
      · 0 replies
    • Joker  »  Nachoooo

      Updated your Avatar : couldnt help myself  cheers!
      · 0 replies
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Forum Statistics

    40.9k
    Total Topics
    573.6k
    Total Posts
×
×
  • Create New...